-
BRONES Romain authored
* Patch the .mapt file to set BAR to 0 * Add timers to xml config * fix the device name
BRONES Romain authored* Patch the .mapt file to set BAR to 0 * Add timers to xml config * fix the device name
Code owners
Assign users and groups as approvers for specific file changes. Learn more.
fofb-opcua-server_0.1.bb 895 B
SUMMARY = "Add an ChimeraTK OPCUA-GenericServer to access PL app"
SECTION = "opt"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = " file://app.mapt \
file://devices.dmap \
file://generic_chimeratk_server_configuration.xml \
"
RDEPENDS_${PN}=" genericdeviceserver-opcua"
FILES_${PN}+="/opt/fofb-opcua-server/*"
do_compile() {
# Replace BAR by 0
awk 'FNR>1 {$5=0} {print}' ${WORKDIR}/app.mapt > ${WORKDIR}/app_bar0.mapt
}
do_install() {
install -d ${D}/opt/fofb-opcua-server/
install -m 0644 ${WORKDIR}/app_bar0.mapt ${D}/opt/fofb-opcua-server/app.mapt
install -m 0644 ${WORKDIR}/devices.dmap ${D}/opt/fofb-opcua-server/devices.dmap
install -m 0644 ${WORKDIR}/generic_chimeratk_server_configuration.xml ${D}/opt/fofb-opcua-server/generic_chimeratk_server_configuration.xml
}