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ds_ScanServer

actuators, sensors, trajectory

data_01,data_02…

Hooks, ScanFunctions

Start,Abort,Pause,Resumeds_DataRecorder

NeXus files

ds_DataFitter

fittedDataArray

Python

SalsaAPI

ds_SimpleScan

Passerelle acteur V3

startRecording Fit data_01

SalsaDB

Configurations

Start Configuration
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Software architecture
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ds_ScanServer

actuators, sensors, trajectory

data_01,data_02…

Hooks, ScanFunctions

Start,Abort,Pause,Resumeds_DataRecorder

NeXus files

ds_DataFitter

fittedDataArray

COMETE Graphical library

CurrentScanResultBean DataFitterBeanDataRecorderBean
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Software architecture
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SalsaAPI

SalsaDB

Configurations
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COMETE graphical library
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TANGONEXUS Archivage

Librairie ATKCOMETE graphical library
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Software packages
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DEVICE_ROOT

ds_ScanServerds_DataRecorder ds_DataFitter

LIVE_ROOT

SALSA

PASSERELLE_ROOT

PasserelleBossanova

SalsaAPIComete

SalsaAPI (Duplication)

DataRecorderBean DataFitterBeanScanResultBean
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Salsa lexicon
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• TANGO : The control system of SOLEIL

• Device : A TANGO programm for remoting a equipement or

processing.

• Attribute : An equipment or a process parameter (eg : position or

integration time).

• Command : An equipment or a process action (eg : Move or Count)

• Scan server device : The Tango device server for processing scan.

• Nexus : Format of files of SOLEIL.

• Sensor : listened Tango parameter

• Actuator : moved Tango parameter

• Hook : A simple Tango command (no argument as Start, Close…)

• Perspective : A custom view disposition.
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Environment variables
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Salsa needs for several environment variables to be set.
• TANGO_HOST

Host of the tango database (localhost:20001)

• SALSA_SERVER_URL

Url of the salsa database (jdbc:mysql://localhost/salsa)

• SALSA_LOGIN

The login of the user connected on Salsa database

• SALSA_PERSPECTIVES_DIRECTORY

The folder for the perspectives files

• SALSA_DEVICE_PREFERENCES

The file for the device configurations

• SALSA_UI_PREFERENCES

The file for the user interface  configurations
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Salsa Preferences settings
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– Log file setting

– Scan server device setting 

– Data Fitter device setting

– Nexus file browser application
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Salsa Mode
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Configuration mode : (“salsa” command)
In this mode you can create, modify and remove a scan configuration.

All the configuration edition views are available in the Menu 

Window > Show View > Configuration Views



XXXXXXX

Salsa Mode
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Configuration manager
The management of several configurations is possible now.
You can Add, Remove, Enable/Disable a TimeBase, Sensor or Actuator on several 
configurations.
Select several configuration in the Scan Manager Tree.
The devices appear in red color, are the uncommon devices.
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Salsa Mode
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Salsa read only: (“salsa-ro” command)
In this mode you can only select a Scan configuration from the bookmark, modify the 
scan configuration (delete or add devices, or hook is not possible).

And you can play the configuration.
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Salsa Mode
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Salsa result : (“salsa-result” command)
In this mode you can only visualize the current scan result.

All the views for the visualization are available in the Menu :

Window > Show View > Result Views
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Create a new configuration
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• New scan configuration. Several kinds of scan exist

1D = dimension X

2D = dimension X et dimension Y

HCS = 1D continue hardware with a time base

K = 1D specific trajectory in 3 phases

E = 1D trajectory visualized differently in a table

Click on the New button 

Or right click on the tree to make appears the 

configuration management menu.
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K Scan

• A K scan is a particular energy scan

• Depending on energy, an absorption threshold is measured

• 3 zones are identified:
– Pre-edge (Emin -> E1): mesures will be done with quick integration times and large steps.

– Edge (Emin -> E1): mesures will be done with finer steps and potentially longer integration

times (E0 is a known theoretical value).

– Post-edge (E2 -> Kmax): mesures will be done with K constant steps, which means energy

increases with distance to E0.

• K = 0.512*√(E - E0), i.e. E = E0 + (K/0.512)².

• At each step, integration time is increased (following formula Time(N) = Tmin × (K / Kmin)N).

• Kmin = 0.512*√(E2 - E0).

• Kmax is a user input.

• More information about this

scan in Jira ticket SCAN-763.
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https://jira.synchrotron-soleil.fr/jira/browse/SCAN-763
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General parameters
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– LINE/EX/SCAN.1/scanNumber

– LINE/EX/SCAN.1/ actuatorsDelay

– LINE/EX/SCAN.1/ zigzag

– LINE/EX/SCAN.1/ onTheFly

– LINE/EX/SCAN.1/ enableScanSpeed

– LINE/EX/SCAN.1/ afterRunActionType

scanserver

attributes
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Scan parameters
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– LINE/EX/SCAN.1/sensors

– LINE/EX/SCAN.1/timebases

– LINE/EX/SCAN.1/actuators

– LINE/EX/SCAN.1/trajectories

– Predefined values defined in the device properties  :

• ActuatorsFile,

• SensorsFile, 

• TimebasesFile

scanserver

attributes
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Hooks configuration
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– LINE/EX/SCAN.1/postActuatorMoveHooks

– LINE/EX/SCAN.1/postIntegrationHooks

– LINE/EX/SCAN.1/postRunHooks

– LINE/EX/SCAN.1/postScanHooks

– LINE/EX/SCAN.1/postStepHooks

– …

scanserver

attributes
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Error strategy
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– LINE/EX/SCAN.1/sensorsErrorStrategy

– LINE/EX/SCAN.1/sensorsRetryCount

– LINE/EX/SCAN.1/contextValidation

scanserver

attributes
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Scan execution

First select a configuration before starting a scan configuration.

When no configuration is selected, the Start button is disabled.
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Start button.

Scan server command:

LINE/EX/SCAN.1/Start

Pause button.

Scan server command:

LINE/EX/SCAN.1/Pause

Resume button.

Scan server command:

LINE/EX/SCAN.1/Resume

Abort button.

Scan server command:

LINE/EX/SCAN.1/Abort
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Display manager

– LINE/EX/SCAN.1/actuatorsDataList

– LINE/EX/SCAN.1/sensorsDataList

– LINE/EX/SCAN.1/sensorsTimestamps

– LINE/EX/SCAN.1/actuatorsTimestamps

– LINE/EX/FIT.1/fittedDataY
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scanserver

attributes

datafitter

attributes
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1D scan result visualization
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– LINE/EX/SCAN.1/data_XX scanserver attribute

– Send the actuator to the selected point.

Click on a point
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2D scan result visualization
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– LINE/EX/SCAN.1/data_XX scanserver attribute

– Send the actuator to the selected point.
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2D scan as N spectra
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• Display a 2D Image as N Spectra in Chart
– LINE/EX/SCAN.1/data_XX scanserver attribute
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Scan functions
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• Executed by the user on demand (except in Abort case) !

– LINE/EX/SCAN.1/afterRunActionType

– LINE/EX/SCAN.1/afterRunActionSensor

– LINE/EX/SCAN.1/afterRunActionActuator

– LINE/EX/SCAN.1/afterRunActionActuatorValue

– Commande LINE/EX/SCAN.1/ExecuteAction

scanserver

attributes



XXXXXXX

Scan historic
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• Current scan historic (can be very useful for debugging !)

– LINE/EX/SCAN.1/historic scanserver attribute



XXXXXXX

Salsa logging
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• Scans executed actions via SalsaAPI historic (historic file)

– ds_simpleScan, passerelle  and Salsa.

– Replay (exactly) a scan via Play button

– Click on the nexus file name to open it a nexus file browser application
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Perspectives
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A perspective is a windows disposition preference.

• Create a perspective:
– Menu Perspective -> New
– Enter a perspective Name

• Load a perspective:
– Menu Perspective -> Check the desired perspective to load.

• Save a prespective:
– Hide and show the desired views (Window menu)
– Organize your views disposition
– Click on Save button
– The perspective is also saved at the software exit.

• Remove a perspective:
– Menu Perspective -> Remove
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Data Fitter views
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• DataFitter integration in the scan chart result
– LINE/EX/FIT.1/fittedDataY

– LINE/EX/FIT.1/deviceAttributeNameX

– LINE/EX/FIT.1/deviceAttributeNameY

data fitter

attributes
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Data recorder views

Salsa User Manual 34

• Data recording service
– LINE/EX/FIT.1/recorderData

• Default configuration of data recording service
– Menu Edit -> Preferences -> Devices

– Set true or false

• Enable/Disable recording service
– Click on the Data recorder button

data recorder attribute
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Bookmarks
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• Bookmarks management
– Create a bookmark

– Fill the bookmark

Enter a simple name for the added configuration



XXXXXXX

Bookmarks
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• Configuration selection via bookmarks

• salsa-ro arguments
– salsa-ro with no argument will display 2 combo boxes:

The  Bookmarks list and the configuration list associated to a 
selected bookmark

– salsa-ro bookmark_name (salsa-ro NewList2) will display 1 
combo box: The configuration list associated to the bookmark 
named in argument

– salsa-ro configuration_name (salsa-ro root/Katy/My1DConfig) will 
display the view with directly the configuration named in argument.
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Salsa search tool
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In order to quickly find a configuration
– Type a text to find in a configuration name

– Click on Next (>>) button or Previous (<<) button to find all 
matching configurations
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Custom Trajectory
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Trajectory YTrajectory X Trajectory Editor

Trajectory Menu
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Salsa open Nexus files
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• Open a nexus file in the databrowser
Click on a nexus file name to open it in the databrowser.
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Get trajectory from scan image
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• Declare a Publisher device in Tango database:
– Device Server name: Publisher/SAV-SCAN-TRAJ

– Device name: tango/CA/PubScanTraj.1

– Properties:

• Configure Salsa to access to Export Trajectory option:
– To get the expected menu in Salsa, more precisely in the « Image » 

tab of the « Scan Result » tab, you have to declare the publisher
that will receive the trajectory.

– Menu Edit -> Preferences, select Devices and fill Publisher field
with tango/CA/PubScanTraj.1

– The following Export Trajectory button will be available:
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Get trajectory from scan image
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• Select points in scan image:
Right click on image -> Selection mode

– Either select n points on image with « Point ROI Mode » tool,

– Or select a line on image with « Line ROI Mode » tool,

– Or go back to default cursor with « Selection Mode » tool.

• Remove points:
– Right click on image -> Selection mode -> « Delete all Rois » red

cross
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Get trajectory from scan image
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• Save trajectory:
– First, choose « X actuator » and « Y actuator » in image tab.

– Click on « Export Trajectory » button

– If a line was chosen, then a step number should be fulfilled.

– The trajectory content (n X,Y couples) will have to be obtained
from the trajectory Spectrum attribute of the Publisher device.
(cf. tango/CA/PubScanTraj.1/trajectory)

• Trajectory extraction:
Example of 5 points

extraction from python:
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