From 9ef6c237a910c7576774313038a0fc4d90d090ae Mon Sep 17 00:00:00 2001
From: Romain BROUCQUART <romain.broucquart@synchrotron-soleil.fr>
Date: Wed, 1 Mar 2023 13:40:23 +0100
Subject: [PATCH] fix(device-tree):Add pl-conf.dtsi to system-top

* Remove DT_FROM_BD_ENABLE. We don't have anything particular in BD.
* Adding pl-conf.dtsi in system-top otherwise is gets lost and unused.
---
 recipes-bsp/device-tree/device-tree.bbappend | 8 ++++++--
 recipes-core/images/zup-image-soleil-fofb.bb | 5 -----
 2 files changed, 6 insertions(+), 7 deletions(-)

diff --git a/recipes-bsp/device-tree/device-tree.bbappend b/recipes-bsp/device-tree/device-tree.bbappend
index b46f37e..c7e30fc 100644
--- a/recipes-bsp/device-tree/device-tree.bbappend
+++ b/recipes-bsp/device-tree/device-tree.bbappend
@@ -3,5 +3,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 SRC_URI_append = " \
     file://pl-conf.dtsi \
 "
-# Force for overlay
-DTC_OFLAGS_append =' -f'
+
+# We need what's in pl-conf.
+# We are not using DTBO for now (cannot build)
+do_configure_append() {
+    echo '/include/ "pl-conf.dtsi"'   >> ${DT_FILES_PATH}/system-top.dts
+}
diff --git a/recipes-core/images/zup-image-soleil-fofb.bb b/recipes-core/images/zup-image-soleil-fofb.bb
index 1d9fd5a..7324be1 100644
--- a/recipes-core/images/zup-image-soleil-fofb.bb
+++ b/recipes-core/images/zup-image-soleil-fofb.bb
@@ -30,8 +30,6 @@ IMAGE_INSTALL_append = " fofb-opcua-server"
 IMAGE_INSTALL_append = " fofb-init"
 IMAGE_INSTALL_append = " xilinx-xvc-server"
 
-IMAGE_FEATURES_append = " fpga-manager"
-
 # We do not need that
 IMAGE_INSTALL_remove = " git python3-pip sudo"
 IMAGE_INSTALL_remove = " fpgautil-init"
@@ -50,6 +48,3 @@ EXTRA_USERS_PARAMS = "\
     usermod -s /bin/zsh -P 'fofb' root; \
     useradd -s /bin/zsh -G sudo -P 'diag91' diag; \
     "
-
-# If the FPGA system has a Block Design, try to generate the Device Tree
-DT_FROM_BD_ENABLE = "1"
-- 
GitLab