From 66447cbfd98a9a751edc21294d01b546ac6d71fe Mon Sep 17 00:00:00 2001
From: Romain Broucquart <romaine.broucquart@synchrotron-soleil.fr>
Date: Tue, 7 Feb 2023 10:30:26 +0000
Subject: [PATCH] Add user diag, add root password, add debug tweaks

Struggling with petalinux update: it is no longer possible to log as
root without the tweaks.

From user diag, it is possible to sudo.
---
 recipes-core/images/zup-image-soleil-fofb.bb | 8 ++++++++
 1 file changed, 8 insertions(+)

diff --git a/recipes-core/images/zup-image-soleil-fofb.bb b/recipes-core/images/zup-image-soleil-fofb.bb
index 45ccef0..cfc7da6 100644
--- a/recipes-core/images/zup-image-soleil-fofb.bb
+++ b/recipes-core/images/zup-image-soleil-fofb.bb
@@ -17,6 +17,7 @@ require ./recipes-core/images/techlab-common.inc
 IMAGE_FEATURES_append = " \
     package-management \
     petalinux-python-modules \
+    debug-tweaks \
     "
 
 # If we want FPGA manager
@@ -43,3 +44,10 @@ IMAGE_FEATURES_remove = " x11 wayland opengl qt jupyter"
 # Remove unwanted features
 DISTRO_FEATURES_remove = " wifi bluetooth 3g nfc"
 
+# User
+inherit extrausers
+EXTRA_USERS_PARAMS = "\
+    usermod -s /bin/zsh -P 'fofb' root; \
+    useradd -s /bin/zsh -G sudo -P 'diag91' diag; \
+    "
+
-- 
GitLab