diff --git a/recipes-core/images/zup-image-soleil-fofb.bb b/recipes-core/images/zup-image-soleil-fofb.bb
index 45ccef04cc0a0eeec8f98b49c0b22aa499f3dd86..cfc7da65f3355ed315d8bec0f23d6ec130898754 100644
--- a/recipes-core/images/zup-image-soleil-fofb.bb
+++ b/recipes-core/images/zup-image-soleil-fofb.bb
@@ -17,6 +17,7 @@ require ./recipes-core/images/techlab-common.inc
 IMAGE_FEATURES_append = " \
     package-management \
     petalinux-python-modules \
+    debug-tweaks \
     "
 
 # If we want FPGA manager
@@ -43,3 +44,10 @@ IMAGE_FEATURES_remove = " x11 wayland opengl qt jupyter"
 # Remove unwanted features
 DISTRO_FEATURES_remove = " wifi bluetooth 3g nfc"
 
+# User
+inherit extrausers
+EXTRA_USERS_PARAMS = "\
+    usermod -s /bin/zsh -P 'fofb' root; \
+    useradd -s /bin/zsh -G sudo -P 'diag91' diag; \
+    "
+